ozztech_logo_white

Apache Web Sunucusu Zero-Day Hatası

Apache Web Sunucusu Zero-Day

Apache Yazılımı, Apache HTTP Sunucusunda geçen hafta projeye ilk kez bildirilen sıfırıncı gün güvenlik hatası için hızlı bir Açık kaynak projesi, CVE-2021-41773 için kamuya açık siber saldırılardan yararlanma kodunun dolaşımda olduğu bir güvenlik düzeltmesi yayınladı. Güvenlik açığı, vahşi ortamda aktif olarak istismar ediliyor ve saldırganların hassas bilgilere erişmesine izin verebileceğini söyledi. Yani Apache Web Sunucusu Zero-Day hassas verilerinizi ortaya atıyor.

Pazartesi günü yayınlanan bir güvenlik tavsiyesine göre , sorun (CVE-2021-41773) yol geçişine ve ardından dosya ifşasına izin verebilir. Yol geçişi sorunları, web sunucusunu veya üzerinde çalışan web uygulamasını kandırarak web kök klasörünün dışında bulunan dosyaları döndürmek için yetkisiz kişilerin bir web sunucusundaki dosyalara erişmesine izin verir. Güvenlik açığı, 10 üzerinden 5,1 CVSS puanı ile Önemli olarak derecelendirilmiştir.

Bu durumda sorun, UNIX ve Windows dahil tüm modern işletim sistemleriyle platformlar arası çalışabilirlik sunan Apache’nin açık kaynaklı web sunucusunun yalnızca 2.4.49 sürümünü etkiler.

Tavsiyeye göre “Apache HTTP Sunucusu 2.4.49’da yol normalleştirmesinde yapılan bir değişiklikte bir kusur bulundu”. “Bir saldırgan, URL’leri beklenen belge kökünün dışındaki dosyalara eşlemek için bir yoldan geçiş saldırısı kullanabilir. Belge kökünün dışındaki dosyalar ‘hepsinin reddedilmesini gerektir’ ile korunmuyorsa, bu istekler başarılı olabilir.”

Apache Web Sunucusu Zero-Day hatası ayrıca, danışma belgesine eklenen ve saldırganların daha sonraki saldırılar için yararlanabileceği hassas bilgiler içerebilen CGI komut dosyaları gibi yorumlanmış dosyaların kaynağını da açığa çıkarabilir.

Positive Technologies’deki saldırı ekibi gibi araştırmacılar, saldırı yolunu doğrulayan hızlı bir şekilde kavram kanıtı istismarları oluşturdular, bu nedenle yakında daha fazla saldırı yolunun halka açık olmasını bekliyoruz:

Tenable, Salı günü yapılan bir Shodan araştırmasının, ABD’de 43.000’i de dahil olmak üzere, savunmasız sürümü çalıştırdığı onaylanan yaklaşık 112.000 Apache HTTP Sunucusunun ortaya çıktığını kaydetti.

Firmanın bloguna göre “Ancak, diğer güvenlik açığı bulunan web sunucuları sürüm bilgilerini göstermeyecek şekilde yapılandırılabilir”.

Kullanıcılar 2.4.50 sürümüne yükselterek kendilerini koruyabilirler.

İlginizi Çekebilecek Makaleler​

Message Broker Nedir?

Message broker, birçok farklı uygulama veya sistem arasında iletişim kurmak için kullanılan bir yazılım aracıdır. Bu araç, bir uygulama tarafından gönderilen mesajları bir veya daha

Devamı »
Loglama Nedir?

Loglama, bilgisayar sistemlerindeki olayları, hataları ve diğer önemli durumları kaydetme işlemidir. Bu kayıtlar, sistem yöneticileri ve geliştiriciler tarafından, sistemlerin işleyişini anlamak, hataları tespit etmek ve

Devamı »
Vcenter Üzerinden ESXI Upgrade’i Nasıl Yapılır?

Öncelikle herkese merhaba arkadaşlar, sizlere Vcenter üzerinde ESXI hostunuzu nasıl upgrade edeceğinizi anlatacağım. Öncelikle hangi versiyona yükselteceksek o versiyonun ISO dosyasını indiriyoruz. Ardından Vcenter’ımızı açıyoruz.

Devamı »
.OrianaLOG Nedir?

.OrianaLOG Nedir? ve Ne işe Yarar?  .OrianaLOG bir sistem veya uygulamanın çalışması sırasında oluşan log (kayıt) dosyalarının toplanması, depolanması, analiz edilmesi ve incelenmesine olanak sağlayan bir

Devamı »